phpBB 3.1 的麻煩

Webmaster Office - 給網站管理員的留言;網站管理員的碎碎念!
回覆文章
頭像
chienwen
小班
文章: 231
註冊時間: 2006.07.25 週二 2:48 PM
來自: Yuanli, Miaoli
聯繫:

phpBB 3.1 的麻煩

文章 chienwen » 2014.03.09 週日 11:52 PM

phpBB 未來的 3.1 版有一個很麻煩的問題要解決,就是這個版本目前仍不支援 MySQL/MariaDB,只支援 PostgreSQL:
https://blog.phpbb.com/2014/02/10/phpbb-3-1-alpha3-preview-release/ 寫: PHP version 5.3.3 or greater
PHP’s json extension
Only PostgreSQL versions 8.3 and above are supported
按照 Mediawiki 的說法, MySQL 轉 PostgreSQL 很簡單,但是 PostgreSQL 轉回 MySQL 不容易:
http://www.mediawiki.org/wiki/Manual:PostgreSQL 寫: From PostgreSQL to MySQL
This is generally not recommended as converting from Postgres data types back to MySQL is not as simple an operation as the reverse.
Mediawiki 須要 MariaDB,phpBB 吵著要 PostgreSQL,傷腦筋~~~
:)

回覆文章